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READ ME FIRST! 
 
 
 

1.0. Kit Contents 
 
The C8051F2XX Development Kit contains the following items: 
 

• C8051F2XX Target Board 
• Serial Adapter (RS-232 to Target Board Protocol Converter) 
• Cygnal IDE and Product Information CD-ROM.  CD content includes: 

• Keil Software 8051 Development Tools (macro assembler, linker, evaluation ‘C’ compiler) 
• Installation utility to install the IDE (SETUP.EXE) 
• Source code examples and register definition file 
• Documentation 

• AC to DC Power Adapter 
• RS232 Serial Cable 
• 7” Ribbon Cable 
• Quick-start Guide 
• C8051F2XX Development Kit User’s Guide (this document) 

 
 
 
 
 
 

NOTE! 
 
The C8051F2XX device installed on the target board features an internal oscillator which is enabled as the 
system clock source on reset.  After reset, the internal oscillator operates at a frequency of 2.0MHz by default but 
may be configured by software to operate at other frequencies (4.0Mhz, 8.0MHz or 16MHz).   Therefore, in many 
applications an external oscillator is not required.   However, if you wish to operate the C8051F2XX device at a 
frequency not available with the internal oscillator, an external crystal may be used.  The target board is designed 
to facilitate the installation of an external crystal at the pads marked Q1.  Following are a few part numbers of 
suitable crystals: 
 
Freq(MHz) Digikey P/N  ECS P/N                                                                     
22.1184 X063-ND  ECS-221-20-1  (20pF loading capacitance) 
18.432  X146-ND  ECS-184-20-1   (20pF loading capacitance) 
11.0592 X089-ND  ECS-110.5-20-1 (20pF loading capacitance) 
 
Refer to the C8051F2XX datasheet for more information on the configuration of the internal oscillator and the use 
of external oscillators. 
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2.0 Hardware Setup 
 
The target board is connected to a PC running the Cygnal IDE via the Serial Adapter as shown in Figure 1.  
 

1. Connect one end of the RS232 serial cable to a serial (COM) port on the PC. 
2. Connect the other end of the RS232 serial cable to the DB-9 connector on the Serial Adapter. 
3. Connect the Serial Adapter to the JTAG connector on the target board using the 10-pin ribbon cable. 
4. Connect the AC/DC power adapter to power jack P1 on the target board. 
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Figure 1.  Hardware Setup 

 
 
 
 

3.0. Software Setup 
 
The included CD-ROM contains the Cygnal Integrated Development Environment (IDE) and additional 
documentation.  Insert the CD-ROM into your PC’s CD-ROM drive.  An installer will automatically launch allowing 
you to install the IDE software or read documentation by clicking buttons on the Installation Panel.  (If the installer 
does not automatically start when you insert the CD-ROM, run “autorun.exe” found in the root directory of the CD-
ROM.)   Refer to the “README.TXT” file on the CD-ROM for the latest information regarding IDE known 
problems and restrictions. 
 
 

4.0. Integrated Development Environment 
 
The included CD-ROM contains the Cygnal Integrated Development Environment (IDE).  The Cygnal IDE 
integrates a source-code editor, source-level debugger and in-system Flash programmer.  The use of third-party 
compilers and assemblers is also supported.  This development kit includes the Keil Software A51 macro 
assembler, banking linker and evaluation version C51 ‘C’ compiler which can be used from within the Cygnal IDE. 
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4.1. System Requirements 
 
The Cygnal IDE requires:  

• Pentium-class host PC running Microsoft Windows 95/98, Windows NT or Windows 2000. 
• One available COM port (1-4). 
• 64MB RAM and 40MB free HD space recommended. 

 
 
4.2. Assembler and Linker 
 
A full-version Keil A51 macro assembler and BL51 banking linker are included with the development kit and are 
installed during IDE installation.  The complete assembler and linker reference manual can be found on-line under 
the Help menu in the IDE or in the “Cygnal\hlp” directory (A51.PDF). 
 
 
4.3. Evaluation C51 ‘C’ Compiler 
 
An evaluation version of the Keil C51 ‘C’ compiler is included with the development kit and is installed during IDE 
installation. The evaluation version of the C51 compiler is the same as the full professional version except code 
size is limited to 4K bytes and the floating point library is not included.  The C51 compiler reference manuals can 
be found in the “Cygnal\hlp” directory (C51.PDF). 
 
 
4.4. Using the Keil Software 8051 Tools with the Cygnal IDE 
 
To perform source-level debug with the IDE, you must configure the Keil 8051 tools to generate an absolute 
object file in the OMF-51 format with object extensions and debug records enabled.  You may build the OMF-51 
absolute object file by calling the Keil 8051 tools at the command line (e.g. batch file or make file) or by using the 
project manager built into the IDE.  The default configuration when using the Cygnal IDE project manager enables 
object extension and debug record generation. 
 
To build an absolute object file using the Cygnal IDE project manager, you must first create a project.  A project 
consists of a set of files, IDE configuration, debug views, and a target build configuration (list of files and tool 
configurations used as input to the assembler, compiler, and linker when building an output object file). 
 
The following sequence illustrates the steps necessary to manually create a project with one or more source files, 
build a program and download the program to the target in preparation for debugging.  (The IDE will automatically 
create a single-file project using the currently open and active source file if you select Build or Make Project 
before a project is defined.)    Refer to Applications Note AN004 in the “Documentation” directory on the CD-
ROM for additional information on using the Keil 8051 tools with the Cygnal IDE. 
 
 
4.4.1.  Creating a New Project 
 

1. Select File -> New File to open an editor window.  Create your source file(s) and save the file(s).  (Color 
syntax highlighting will be enabled once the file is saved with a recognized extension such as .c, .h or 
.asm.) 

 
2. Right-click on “New Project” in the Project Window.  Select Add files to project.  Select a file to add to 

the project in the file browser and click Open.  
 

3. Select the File Group to which you want to add the file(s) and click Add Group.  Repeat steps 2 and 3 
for each file you want to add to the project. 
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4. For each of the files in the Project Window that you want assembled, compiled and linked into the target 
build, right-click on the file name and select Add file to build.  Each file will be assembled or compiled as 
appropriate (based on file extension) and linked into the build of the absolute object file.   

 
4.4.2. Building and Downloading the Program for Debugging 
 

1. Once all source files have been added to the target build, click on the Build button in the toolbar (or 
select Project -> Build/Make Project to build and download the program to the target hardware for 
debug. 
 
By default, if the program build is successful, the IDE will automatically connect to the target and 
download the program for debug.  (This may be disabled by deselecting Enable automatic 
connect/download after build in the Projects -> Target Build Configuration dialog.)  If errors occur 
during the build process, the IDE will not attempt the download.   

 
2. Save the project when finished with the debug session to preserve the current target build configuration, 

editor settings and the location of all open debug views.  To save the project, right-click on the New 
Project entry in the Project Window and select Save as a project.   

 
 
4.5. Example Source Code 
 
Example source code is provided in the “Examples” directory on the Cygnal IDE CD-ROM.  These files may be 
used as a template for code development.  By default, the C8051F0XX exits reset with the watchdog timer (WDT) 
enabled.  The BLINK.ASM file used in the “Quick Start” demo illustrates the correct method for disabling the WDT 
as well as configuring the Port I/O crossbar. 
 
 
4.6. Register Definition File 
 
Register definition files defining all SFR registers and bit-addressable control/status bits, are provided in the 
“Examples” directory on the Cygnal IDE CD-ROM.  The register and bit names used in this file are identical to 
those used in the C8051FXXX datasheets.  These files are also installed in the default search path used by the 
Keil Software 8051 tools.  Therefore, when using the Keil 8051 tools (A51, C51) it is not necessary to copy a 
register definition file to each project’s file directory. 

 

5.0. Target Board 
 
The target board provides access to all C8051F2XX signals (except the four JTAG signals: TCK, TMS, TDO and 
TDI used to connect the Emulation Cartridge – these are accessed using test points in place near the J4 header) 
via the 64-pin connector J2.  A small through-hole prototyping area is also provided.  All I/O signals routed to 
connector J2 are also routed to through-hole connection points between J2 and the prototyping area (see Figure 
2).  The signal layout pattern of these connection points is identical to the adjacent J2 connector pins.  Table 1 
shows the pin-out of the J2 connector.  
 
An Analog I/O Configuration Jumper (J6) provides the ability to route analog I/O signals from the C8051F2XX to a 
terminal block in addition to connector J2 by installing shorting blocks on J6.  If shorting jumpers are installed on 
J5 and J7, then the analog signals routed through J6 will go to the C8051F2XX’s port pins P3.0 and/or P3.1.  
These port pins (any port pins) may be configured as inputs to the on-chip ADC for evaluation.  J6 also allows the 
user to route analog signals from the terminal block to port pins P1.3 and P1.4, which can be configured as inputs 
to Comparator 1.  The target board also features a low-pass filter that can be connected to port pin P2.7 for 
implementing a pulse-width modulator (PWM).  This PWM is also routed to J6 to provide a user controlled analog 
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voltage level.  This voltage signal can be used to conveniently evaluate the on-chip ADC by placing a shorting 
jumper on J6 (provided the J5 or J7 jumper is shorted).  Refer to Figure 3 to determine the shorting block 
installation positions required to connect the desired analog signal to the terminal block.  
 
As aforementioned, the target board features a low-pass filter that may be connected to port pin P2.7.  This was 
placed on the board to provide a user controlled PWM digital-to-analog converter that can be easily routed to the 
on-chip ADC for evaluation.  The C8051F2XX can be programmed to provide a PWM input to the low-pass filter, 
then sample this signal using the on-chip ADC, and we have provided an application note with software titled, “16-
Bit PWM Using On-Chip Timer”.  This application note and software can be found on the CD-ROM.  To route the 
PWM signal to the ADC, a jumper should be placed on the connector labeled “PWMIN”, and a jumper placed on 
connector “P3.0AIN” or “P3.1AIN”.  Connector J6 is used to connect the PWM voltage to the P3.0AIN or P3.1AIN 
signal routed to the corresponding port pins (See Figure 3).  These port pins are then configured for use by the 
ADC. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2.  C8051F2XX Target Board 
 
 
 
Two switches and two LEDs are provided on the target board.  Switch SW1 is connected to the RESET pin of the 
C8051F2XX.  Pressing SW1 puts the C8051F2XX in its hardware-reset state.  The C8051F2XX will leave the 
reset state after SW1 is released.  Switch SW2 is connected to the C8051F2XX’s Port Pin 2.4 (P2.4) general 
purpose I/O (GPIO) pin.   Pressing SW2 generates a logic high signal on the P2.5 pin.  Releasing SW2 returns 
the signal level to logic low.  The P2.5 signal is also routed to a pin on the connector labeled “P2.5” located SW2.  
Remove the shorting block from the “P2.5” connector to disconnect SW2 from P2.5. 
 
The LED labeled PWR is used to indicate a power connection to the target board.  The LED labeled P2.4 is 
connected to the C8051F2XX’s Port Pin 2.4 (P2.4) GPIO pin through the connector labeled “LED” located by the 
LED’s.  The P2.4 signal is also routed to a pin on the J2 connector.  Remove the shorting block from the “LED” 
connector to disconnect the LED from P2.4. 
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5.2. C8051F2XX Target Board Connectors 
 
Refer to Figure 2 for the locations of the following connectors: 
 

P1 -  Power connector (accepts input from 7 to 15 VDC unregulated power adapter) 
P2.5 -  Connects SW2 to C8051F2XX Port 2.5 pin 
J2 -  64-pin I/O connector providing access to all C8051F2XX I/O signals 
P2.5 -  Connects LED D2 to C8051F2XX Port 2.4 pin 
JTAG -  Used to connect the Emulation Cartridge to the target board via a 10-pin ribbon cable 
VDDMONEN -  Ties VDD monitor enable signal to +3VD2 or ground to enable/disable the VDD monitor. 
PWMIN -  Used to connect PWM low-pass filter to port pin P2.7 to produce voltage level that can be 

routed to the C8051F2XX and on-chip ADC. 
J6 -  Used to route terminal block signals and PWM signal to analog function port pins on the 

C8051F2XX. 
 

 
 
 
5.2.1. C8051F2XX Target Board I/O Connector Pin Descriptions (J2) 
 
 
Pin Description  Pin Description 
1,46,64 +3VD2 (voltage supply)  20 P2.7 
2 XTAL1  21 P2.4 
3 P1.6  22 P2.5 
4 P1.7  23 P2.2 
5 P1.4  24 P2.3 
6 P1.5  25 P2.0 
7 P1.2  26 P2.1 
8 P1.3  27 P3.6 
9 P1.0  28 P3.7 
10 P1.1  29 P3.4 
11 P0.6  30 P3.5 
12 P0.7  31 P3.2 
13 P0.4  32 P3.3 
14 P0.5  33 P3.0 
15 P0.2  34 P3.1 
16 P0.3  36 /RST 
17 P0.0  39,41,42,45,47,63 GND 
18 P0.1  48,50 PWM (pulse-width modulator) 
19 P2.6  53 VREF 

 
 

Table 1. J2 Pin Descriptions 
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3.2.3. C8051F2XX Target Board Analog I/O Configuration Jumper (J6) 
 
Analog signals can be routed from AIN1 and AIN2 on the terminal block to port pins P1.3/CP1+ and P1.4/CP1- to 
evaluate Analog Comparator 1.  Similarly, AIN1 AIN2, and the on-board PWM voltage signal can be connected to 
P3.0AIN/P3.1AIN to route signals to the on-chip analog-to-digital Converter (ADC) for evaluation.  These 
connections are accomplished by placing shorting jumpers on the appropriate adjacent J6 pins according to 
Figure 3 below. 
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Figure 3.  J6 Configuration Jumper 
 
 
 
3.2.2. C8051F2XX Target Board JTAG Connector Pin Descriptions 
 

Pin Description 
1 2.7 to 3.6VDC Input 
2, 3, 9 Ground 
4 TCK 
5 TMS 
6 TDO 
7 TDI 
8, 10 Not Connected 

 

6.0. Serial Adapter 
 
The Serial Adapter provides the interface between the PC’s RS232 serial port and the C8051F2XX’s JTAG-
based, in-system debug/programming circuitry.   The Serial Adapter may be powered from the target board via 
the Serial Adapter’s 10-pin JTAG connector or it may be powered directly from the included AC/DC power 
adapter.  (The target board can not be powered from the Serial Adapter.)   
 
Notes: 
 

1. When powering the Serial Adapter via the JTAG connector, the input voltage to the JTAG connector’s 
power pin must be 3.0 to 3.6VDC.  Otherwise, the Serial Adapter must be powered directly by connecting 
the AC/DC adapter to the Serial Adapter’s DC power jack.  

 
2. The Serial Adapter requires a target system clock of 32Khz or greater.  
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6.1. Serial Adapter JTAG Connector 
 
 
 
Pin Description 
1 3.0 to 3.6VDC Input 
2 Ground 
4 TCK 
5 TMS 
6 TDO 
7 TDI 
3,8,9,10 Not Connected 

 
 

 
 

Figure 4. Serial Adapter JTAG Connector 
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